This content has been machine translated dynamically.
Dieser Inhalt ist eine maschinelle Übersetzung, die dynamisch erstellt wurde. (Haftungsausschluss)
Cet article a été traduit automatiquement de manière dynamique. (Clause de non responsabilité)
Este artículo lo ha traducido una máquina de forma dinámica. (Aviso legal)
此内容已经过机器动态翻译。 放弃
このコンテンツは動的に機械翻訳されています。免責事項
이 콘텐츠는 동적으로 기계 번역되었습니다. 책임 부인
Este texto foi traduzido automaticamente. (Aviso legal)
Questo contenuto è stato tradotto dinamicamente con traduzione automatica.(Esclusione di responsabilità))
This article has been machine translated.
Dieser Artikel wurde maschinell übersetzt. (Haftungsausschluss)
Ce article a été traduit automatiquement. (Clause de non responsabilité)
Este artículo ha sido traducido automáticamente. (Aviso legal)
この記事は機械翻訳されています.免責事項
이 기사는 기계 번역되었습니다.책임 부인
Este artigo foi traduzido automaticamente.(Aviso legal)
这篇文章已经过机器翻译.放弃
Questo articolo è stato tradotto automaticamente.(Esclusione di responsabilità))
Translation failed!
区域
简介
Citrix DaaS(以前称为 Citrix Virtual Apps and Desktops™ 服务)部署跨越通过 WAN 连接的广泛分散位置时,可能会面临网络延迟和可靠性方面的挑战。使用区域可以帮助远程区域的用户连接到资源,而无需强制其连接遍历 WAN 的大部分区域。在 Citrix DaaS 环境中,每个资源位置都被视为一个区域。
区域在各种规模的部署中都很有用。您可以使用区域将应用程序和桌面置于更靠近用户的位置,从而提高性能。区域可用于灾难恢复、地理位置分散的数据中心、分支机构、云或云中的可用区。
在本文中,“本地”一词指正在讨论的区域。例如,“VDA 向本地 Cloud Connector 注册”表示 VDA 向 VDA 所在区域中的 Cloud Connector 注册。
与本地 Citrix Virtual Apps and Desktops 环境中的区域的区别
Citrix DaaS™ 环境中的区域与本地 Citrix Virtual Apps and Desktops 部署中的区域相似但不完全相同。
- 在 Citrix DaaS 中,当您创建资源位置并向其添加 Cloud Connector 时,区域会自动创建。与本地部署不同,Citrix DaaS 环境不将区域分类为主区域或卫星区域。
- 在 XenApp 6.5 及更早版本中,区域包含数据收集器。Citrix DaaS 不将数据收集器用于区域。此外,故障转移和首选区域的工作方式也不同。
区域中包含什么
区域等同于资源位置。当您创建资源位置并安装 Cloud Connector 时,会自动为您创建一个区域。每个区域都可以根据您的独特需求和环境拥有不同的资源集。

每个区域必须始终至少有一个 Cloud Connector,最好有两个或更多,以实现冗余。
您可以将计算机目录、虚拟机管理程序、主机连接、用户和应用程序放置在区域中。区域还可以包含 Citrix Gateway。
将项目放置在区域中会影响 Citrix DaaS 与它们以及与它们相关的其他对象进行交互的方式。
- 当管理程序连接放置在某个区域中时,假定通过该连接管理的所有管理程序也驻留在该区域中。
- 当计算机目录放置在某个区域中时,假定目录中的所有 VDA 都在该区域中。
- 可以将 Citrix Gateway 实例添加到区域。创建资源位置时,系统会提供添加 Citrix Gateway 的选项。当 Citrix Gateway 与某个区域关联时,在连接到该区域中的 VDA 时,将优先使用该 Citrix Gateway。
- 理想情况下,区域中的 Citrix Gateway 用于从其他区域或外部位置进入该区域的用户连接。您也可以将其用于区域内的连接。
- 创建更多资源位置并在其中安装 Cloud Connector(这会自动创建更多区域)后,您可以在区域之间移动资源。这种灵活性伴随着将最适合紧密协作的项分开的风险。例如,将目录移动到与创建目录中计算机的连接(主机)不同的区域可能会影响性能。因此,在区域之间移动项之前,请考虑潜在的意外影响。将目录及其使用的主机连接保留在同一区域中。
如果区域与 Citrix Cloud 之间的连接失败,本地主机缓存功能可使区域中的 Cloud Connector 继续代理与该区域中 VDA 的连接。(该区域必须安装 StoreFront。)例如,这在办公室中很有效,即使连接办公室与公司网络的 WAN 链路发生故障,工作人员也可以使用本地 StoreFront 站点访问其本地资源。有关详细信息,请参阅本地主机缓存。
VDA 注册位置
VDA 必须至少为 7.7 版本才能使用以下区域注册功能:
- 区域中的 VDA 向本地 Cloud Connector 注册。
- 只要该 Cloud Connector 可以与 Citrix Cloud™ 通信,正常操作就会继续。
- 如果该 Cloud Connector 正在运行但无法与 Citrix Cloud 通信(并且该区域具有本地 StoreFront),它将进入本地主机缓存中断模式。
- 如果 Cloud Connector 发生故障,该区域中的 VDA 会尝试向其他本地 Cloud Connector 注册。一个区域中的 VDA 绝不会尝试向另一个区域中的 Cloud Connector 注册。
- 如果您在区域中添加或删除 Cloud Connector(使用 Citrix Cloud 管理控制台),并且启用了自动更新,则该区域中的 VDA 会收到可用本地 Cloud Connector 的更新列表,以便它们知道可以向谁注册以及接受来自谁的连接。
- 如果您将计算机目录移动到另一个区域(使用 Studio),则该目录中的 VDA 会重新向您移动目录到的区域中的 Cloud Connector 注册。移动目录时,请确保也将任何关联的主机连接移动到同一区域。
- 在中断期间(当区域中的 Cloud Connector 无法与 Citrix Cloud 通信时),只有与在该区域中注册的计算机关联的资源才可用。
区域首选项
在多区域站点中,区域首选项功能为管理员提供了更大的灵活性,可以控制使用哪个 VDA 启动应用程序或桌面。
区域首选项的工作原理
区域首选项有三种形式。您可能希望根据以下因素使用特定区域中的 VDA:
- 应用程序数据的存储位置。这称为应用程序主目录 (application home)。
- 用户主数据(例如配置文件或主共享)的位置。这称为用户主目录 (user home)。
- 用户的当前位置(Citrix Workspace 应用程序正在运行的位置)。这称为用户位置 (user location)。用户位置需要最低 StoreFront 3.7 和 Citrix Gateway(以前称为 NetScaler Gateway)11.0-65.x。
下图显示了一个多区域配置示例。

在此示例中,VDA 分布在三个区域中,但它们都属于同一个交付组。因此,Citrix DaaS 代理可以选择使用哪个 VDA 来处理用户启动请求。此示例说明用户可以在不同位置运行其 Citrix Workspace 应用程序端点。用户 A 在区域 1 中使用带有 Citrix Workspace 应用程序的设备。用户 B 在区域 2 中使用设备。同样,用户的文档可以存储在不同的位置。用户 A 和 B 使用位于区域 1 的共享。用户 C 使用区域 3 中的共享。此外,其中一个已发布的应用程序使用位于区域 1 的数据库。
通过为用户或应用程序配置主区域,可以将用户或应用程序与区域关联。然后,代理使用这些关联来帮助选择会话将启动的区域(如果资源可用)。您可以执行以下操作:
- 通过将用户添加到区域来配置用户的主区域。
- 通过编辑应用程序的属性来配置应用程序的主区域。
用户或应用程序一次只能有一个主区域。(当由于用户组成员身份而导致多个区域成员身份时,用户可能会出现例外情况。但是,即使在这种情况下,代理也只使用一个主区域。)
尽管可以配置用户和应用程序的区域首选项,但代理仅为一次启动选择一个首选区域。选择首选区域的默认优先级顺序是:应用程序主目录 > 用户主目录 > 用户位置。当用户启动应用程序时:
- 如果该应用程序具有配置的区域关联(应用程序主区域),则首选区域是该应用程序的主区域。
- 如果应用程序没有配置的区域关联,但用户有(用户主区域),则首选区域是该用户的主区域。
- 如果应用程序和用户都没有配置的区域关联,则首选区域是用户正在运行 Citrix Workspace 应用程序实例的区域(用户位置)。如果未定义该区域,则使用随机 VDA 和区域选择。负载平衡应用于首选区域中的所有 VDA。如果没有首选区域,则负载平衡应用于交付组中的所有 VDA。
自定义区域首选项
当您为用户或应用程序配置(或删除)主区域时,您还可以进一步限制区域首选项的使用方式(或不使用方式)。
- 强制使用用户主区域: 在交付组中,您可以指定“在用户的主区域中启动会话(如果用户有主区域),如果主区域中没有可用资源,则不故障转移到其他区域。”如果您想避免在区域之间复制大型配置文件或数据文件的风险,此限制会很有帮助。换句话说,您宁愿拒绝会话启动,也不愿在不同区域中启动会话。
- 强制使用应用程序主区域: 同样,当您为应用程序配置主区域时,您可以指定“仅在该区域中启动应用程序,如果应用程序的主区域中没有可用资源,则不故障转移到其他区域。”
- 无应用程序主区域,并忽略配置的用户主区域: 如果您未指定应用程序的主区域,您还可以指定“在该应用程序启动时,不考虑任何已配置的用户区域。”例如,如果您希望用户在其机器附近运行特定应用程序的 VDA 上,即使某些用户可能有不同的主区域,也可以使用用户位置区域首选项。
首选区域如何影响会话使用
当用户启动应用程序或桌面时,代理程序优先使用首选区域,而不是使用现有会话。
如果启动应用程序或桌面的用户已经有一个适用于正在启动的资源的会话(例如,可以对应用程序使用会话共享,或者会话已在运行正在启动的资源),但该会话位于非用户/应用程序首选区域的 VDA 上,则系统可能会创建新会话。此操作满足在正确区域中启动(如果该区域有可用容量),优先于重新连接到非首选区域中的会话以满足该用户的会话要求。
为防止无法再访问的孤立会话,即使现有已断开连接的会话位于非首选区域,也允许重新连接到这些会话。
满足启动的会话的理想顺序是:
- 重新连接到首选区域中的现有会话。
- 重新连接到非首选区域中的现有已断开连接的会话。
- 在首选区域中启动新会话。
- 重新连接到非首选区域中已连接的现有会话。
- 在非首选区域中启动新会话。
其他区域首选项注意事项
-
如果您为用户组(例如安全组)配置了主区域,则该组的用户(通过直接或间接成员身份)将与指定区域关联。但是,用户可以是多个安全组的成员,因此可能通过其他组成员身份配置了不同的主区域。在这种情况下,确定该用户的主区域可能会不明确。
如果用户配置了并非通过组成员身份获得的主区域,则该区域将用于区域首选项。通过组成员身份获得的任何区域关联都将被忽略。
如果用户仅通过组成员身份获得了多个不同的区域关联,则代理会随机选择其中一个区域。在代理做出此选择后,该区域将用于后续会话启动,直到用户的组成员身份发生变化。
-
用户位置区域首选项要求 Citrix Gateway 通过其连接的端点设备检测 Citrix Workspace 应用程序。Citrix 必须配置为将 IP 地址范围与特定区域关联。发现的区域身份必须通过 StoreFront 传递到 Citrix DaaS。
尽管是为本地区域使用而编写的,但 区域首选项内部原理 博客文章包含相关的技术详细信息。
管理区域的权限
完全管理员可以执行所有受支持的区域管理任务。在区域之间移动项目不需要与区域相关的权限(区域读取权限除外)。但是,您必须拥有要移动项目的编辑权限。例如,要将计算机目录从一个区域移动到另一个区域,您必须拥有该目录的编辑权限。
如果您使用 Citrix Provisioning™: 当前的 Citrix Provisioning 控制台不识别区域,因此 Citrix 建议使用 Studio 创建要放置在特定区域中的计算机目录。创建目录后,您可以使用 Citrix Provisioning 控制台在该目录中预配计算机。
区域创建
当您在 Citrix Cloud 中创建资源位置,然后将 Cloud Connector 添加到该资源位置时,Citrix DaaS 会自动创建并命名一个区域。您可以选择稍后添加描述。
创建多个资源位置(并自动创建区域)后,您可以将资源从一个区域移动到另一个区域。
资源位置和区域会定期同步,通常大约每五分钟同步一次。因此,如果您在 Citrix Cloud 中更改资源位置的名称,该更改会在五分钟内传播到关联的区域。
添加或更改区域描述
尽管您无法更改区域的名称,但可以添加或更改其描述。
- 在 Studio 中,选择左侧窗格中的“区域”。
- 在中间窗格中选择一个区域,然后在操作栏中选择“编辑区域”。
- 添加或更改区域描述。
- 选择“确定”或“应用”。
将资源从一个区域移动到另一个区域
- 在 Studio 中,选择左侧窗格中的“区域”。
- 在中间窗格中选择一个区域,然后选择一个或多个项目。
- 将项目拖动到目标区域,或在操作栏中选择“移动项目”,然后指定要将它们移动到哪个区域。(尽管您可以选择 Cloud Connector,但实际上无法将它们移动到不同的区域。)
确认消息会列出您选择的项目,并询问您是否确定要移动所有这些项目。
请记住:当计算机目录使用到虚拟机管理程序或云服务的主机连接时,请确保目录和连接位于同一区域。否则,性能可能会受到影响。如果您移动其中一个,请同时移动另一个。
区域删除
您无法删除区域。但是,您可以删除资源位置(在移除其 Cloud Connector 之后)。删除资源位置会自动删除区域。
- 如果区域不包含任何项目(例如目录、连接、应用程序或用户),则该区域将在区域和资源位置之间的下次同步期间删除。同步每五分钟进行一次。
- 如果区域包含项目,则在所有项目移除后,该区域将自动删除。
为用户添加主区域
为用户配置主区域也称为将用户添加到区域。
- 在 Studio 中,选择左侧窗格中的区域。
- 在中间窗格中选择一个区域,然后在操作栏中选择将用户添加到区域。
- 在将用户添加到区域对话框中,选择添加,然后选择要添加到区域的用户和用户组。如果您指定的用户已拥有主区域,则会显示一条消息,提供两个选项:是 = 仅添加您指定的没有主区域的用户;否 = 返回用户选择对话框。
- 选择确定。
对于已配置主区域的用户,您可以要求会话仅从其主区域启动:
- 创建或编辑交付组。
- 在用户页面上,选中要求会话在用户的主区域中启动(如果已配置)复选框。
该交付组中用户启动的所有会话都必须从该用户主区域中的计算机启动。如果交付组中的用户没有配置主区域,则此设置无效。
为用户移除主区域
此过程也称为将用户从区域中移除。
- 在 Studio 中,选择左侧窗格中的区域。
- 在中间窗格中选择一个区域,然后选择操作栏中的从区域中删除用户。
- 在将用户添加到区域对话框中,选择删除,然后选择要从区域中删除的用户和组。此操作仅从区域中删除用户。这些用户仍保留在其所属的交付组中。
- 出现提示时确认删除。
管理应用程序的本地区域
为应用程序配置本地区域也称为将应用程序添加到区域。默认情况下,在多区域环境中,应用程序没有本地区域。
应用程序的本地区域在应用程序属性中指定。您可以在将应用程序添加到组时或之后配置应用程序属性。
- 在创建交付组或将应用程序添加到现有组时,在向导的应用程序页面上选择属性。
- 要在添加应用程序后更改其属性,请在左侧窗格中选择区域。选择一个应用程序,然后选择操作栏中的属性。
在应用程序属性/设置的区域页面上:
- 如果您希望应用程序具有本地区域:
- 选择使用选定的区域进行决定单选按钮,然后选择该区域。
- 如果您希望应用程序仅从选定的区域启动(而不是从任何其他区域启动),请选中区域选择下方的复选框。
- 如果您不希望应用程序具有本地区域:
- 选择不配置本地区域单选按钮。
- 如果您不希望代理在启动此应用程序时考虑任何已配置的用户区域,请选中单选按钮下方的复选框。在这种情况下,应用程序和用户本地区域都不会用于确定此应用程序的启动位置。
其他包含指定区域的操作
如果您有多个区域,则可以在添加主机连接或创建目录时指定区域。区域在选择列表中按字母顺序排列。默认情况下,将选择按字母顺序排列的第一个名称。
故障排除
Studio 会主动发出警报,确保您的 本地主机缓存 和区域配置正确,以便您可以在中断影响用户之前及时解决问题。此功能有助于维护用户对关键任务工作负载的持续访问。
每个存在问题的区域都会显示一个故障排除选项卡。
要检查与区域相关的问题,请按照以下步骤操作:
- 转到区域,然后单击带有警告图标的区域。
- 转到下部窗格中的故障排除选项卡并阅读其中的信息。
注意:
诊断信息每小时更新一次。
故障排除信息示例:
下表提供了与区域相关的警告和错误的完整列表:
| 严重性 | 可能的问题 | 建议的操作 |
|---|---|---|
| 警告 | 资源位置包含多个域。在本地主机缓存模式下,包含多个域的资源位置可能会导致 VDA 注册延迟或失败。 | 重新配置您的资源位置,以使所有 Cloud Connector 位于同一域中。有关支持的多域配置的更多信息,请参阅 Citrix Cloud Connector 技术详细信息。 |
| 警告 | 资源位置中的主机连接数超过了建议的限制,这可能会导致性能下降。 | 减少资源位置中的主机连接数,使其不超过建议的限制。请参阅 限制。 |
| 警告 | 资源位置中只有一个 Cloud Connector。 | 为了实现高可用性,请在每个资源位置安装两个 Cloud Connector。请参阅 Citrix Cloud Connector 技术详细信息。 |
| 警告 | 每个插槽的 CPU 数量少于建议值,这可能会导致本地主机缓存模式下的性能下降。 | 确保每个 Cloud Connector 都满足每个插槽的最低 CPU 要求。请参阅 本地主机缓存的推荐计算配置。 |
| 警告 | StoreFront 未向此资源位置中的所有 Cloud Connector 发送 STA 请求。 | 确保所有 Cloud Connector 都已作为 STA 服务器添加到 StoreFront 和 NetScaler® Gateway,以避免在本地主机缓存模式下启动失败。 |
| 警告 | 在资源位置中检测到 StoreFront,但资源位置中至少有一个连接器未接收 StoreFront 流量。StoreFront 流量缺失会影响可扩展性,并导致进入高可用性模式时出现问题。 | 确保所有 Cloud Connector 都已在 StoreFront 中列为资源源,并检查 StoreFront 是否可以与资源源中指定端口上的所有列出的连接器通信。 |
| 警告 | 资源位置有多个选定的本地主机缓存代理。拥有多个选定的本地主机缓存代理可能导致 VDA 注册在本地主机缓存模式下在连接器之间分配,从而导致间歇性启动失败。 | 确保连接器可以在 http://<FQDN_OF_PEER_CONNECTOR>:80/Citrix/CdsController/ISecondaryBrokerElection 处通信。请参阅 具有多个 Cloud Connector 的区域。 |
| 警告 | 逻辑 CPU 处理器数量少于建议值,这可能导致本地主机缓存模式下的性能下降。 | 确保每个 Cloud Connector 都满足本地主机缓存的最低逻辑 CPU 处理器要求。请参阅 本地主机缓存的推荐计算配置。 |
| 警告 | RAM 少于建议值,这可能导致本地主机缓存模式下的性能下降。 | 确保每个 Cloud Connector 都满足本地主机缓存的最低 RAM 要求。请参阅 本地主机缓存的推荐计算配置。 |
| 错误 | 资源位置中的 VDA 数量多于建议值,这将导致本地主机缓存模式下的 VDA 注册失败。 | 将此资源位置中的 VDA 数量减少到不超过建议的限制。请参阅 限制。 |
| 错误 | 区域中的所有 Cloud Connector 都无法访问。此资源位置中的 VDA 应通过本地主机缓存或服务连续性可用。 | 检查区域中 Cloud Connector 的连接性,并检查注册表以确认是否通过注册表强制启用 LHC 模式。如果未通过注册表强制启用 LHC,请考虑运行 Cloud Connector 连接检查实用程序。如果问题仍然存在,请提交支持票证。 |
| 错误 | 逻辑 CPU 处理器数量少于建议值,这可能会导致性能下降。 | 确保每个 Cloud Connector 都满足最低逻辑 CPU 处理器要求。请参阅 Citrix Cloud Connector 技术详细信息。 |
| 错误 | RAM 少于建议值,这可能会导致性能下降。 | 确保每个 Cloud Connector 都满足最低 RAM 要求。请参阅 Citrix Cloud Connector 技术详细信息。 |
要获取区域中详细的错误配置报告,请运行 PowerShell cmdlet Get-ConfigMisconfigurationReport。添加的详细信息包括哪些连接器配置错误、当前的错误配置以及建议的配置等信息。
共享
共享
This Preview product documentation is Citrix Confidential.
You agree to hold this documentation confidential pursuant to the terms of your Citrix Beta/Tech Preview Agreement.
The development, release and timing of any features or functionality described in the Preview documentation remains at our sole discretion and are subject to change without notice or consultation.
The documentation is for informational purposes only and is not a commitment, promise or legal obligation to deliver any material, code or functionality and should not be relied upon in making Citrix product purchase decisions.
If you do not agree, select I DO NOT AGREE to exit.
