XenMobile® Server

配置基于证书的 EWS 身份验证以实现 Secure Mail 推送通知

Contributed by Vijay Kumar Kunchakuri

为确保 Secure Mail 推送通知正常工作,您必须为 Exchange Server 配置基于证书的身份验证。当 Secure Hub 在 XenMobile® 中通过基于证书的身份验证进行注册时,这是必需的。

您需要在 Exchange 邮件服务器上为 Active Sync 和 Exchange Web Services (EWS) 虚拟目录配置基于证书的身份验证。

除非您完成这些配置,否则 Secure Mail 推送通知的订阅将失败,并且 Secure Mail 中不会出现徽章更新。

本文介绍了配置基于证书的身份验证的步骤。这些配置专门针对 Exchange Server 上的 EWS 虚拟目录。

要开始配置,请执行以下操作:

  1. 登录到安装了 EWS 虚拟目录的服务器。

  2. 打开 IIS 管理器控制台。

  3. 在 Default Web Site 下,单击 EWS 虚拟目录。

    身份验证、SSL、配置编辑器管理单元位于 IIS 管理器控制台的右侧

    IIS 管理器控制台的图像

  4. 确保 EWS 的 Authentication 设置已按以下图示进行配置。

    IIS 管理器控制台的图像

  5. 配置 EWS 虚拟目录的 SSL Settings。

    1. 选中 Require SSL 复选框。

    2. 在 Client Certificates 下,单击 Require。如果其他 EWS 邮件客户端使用用户名和密码作为凭据连接到 Exchange Server 进行身份验证,则可以将此选项设置为 Accept。

    IIS 管理器控制台的图像

  6. 单击 Configuration Editor。在 Section 下拉列表中,导航到以下部分:

    • system.webServer/security/authentication/clientCertificateMappingAuthentication
  7. 将 enabled 值设置为 True。

    IIS 管理器控制台的图像

  8. 单击 Configuration Editor。在 Section 下拉列表中,导航到以下部分:

    • system.webServer/serverRuntime
  9. 将 uploadReadAheadSize 值设置为 10485760 (10 MB) 或 20971520 (20 MB),或设置为您的组织所需的值。

    重要提示:

    如果您未正确设置此值,订阅 EWS 推送通知时,基于证书的身份验证可能会失败,并显示错误代码 413。

    请勿将此值设置为 0。

有关详细信息,请参阅以下第三方资源:

IIS 管理器控制台的图像

有关故障排除 Secure Mail iOS 推送通知问题的详细信息,请参阅此 Citrix 支持知识中心文章。

相关信息

配置基于证书的 EWS 身份验证以实现 Secure Mail 推送通知