トラブルシューティング
ウィンドウズ 365 への接続
Windows 365への接続で問題が発生している場合は、以下を確認してください。
- IntuneでWindows 365 Citrix connector™が有効になっていることを確認してください。
- Windows 365に接続する際に提供された資格情報に適切な権限があることを確認してください。
- Citrix Cloudに接続されているEntra IDディレクトリが、接続しようとしているIntune/Windows 365インスタンスと同じテナントにあることを確認してください。
注:
Azureでのアプリケーション権限の伝播に遅延が生じると、接続が失敗する場合があります。15分以内にWindows 365への接続を再試行すると、問題が解決する可能性があります。
VDA のインストールと構成
VDAのインストールと構成で問題が発生している場合は、以下を確認してください。
- エラーが表示されず、Citrix®エンタイトルメントの割り当て後にVDAがインストールされていない場合は、VDAのインストールと構成が完了するのに十分な時間が経過していることを確認してください。これには最大60分かかる場合があります。
- IntuneでWindows 365 Citrix connectorが有効になっていることを確認してください。
- 前提条件セクションおよびWindows 365ドキュメントに記載されているすべての接続要件が満たされていることを確認してください。
- 詳細を確認し、IntuneでVDAのインストールを再試行してください。
- デバイス > Windows 365 > すべてのCloud PC に移動します。
- 「サードパーティコネクタ」列が表示されていることを確認してください。この列は、「列 > サードパーティコネクタ」を選択して追加できます。
- VDA をインストールする Cloud PC を見つけます。
- 「サードパーティコネクタ」列の下のメッセージを確認します。「Citrix install failed」と表示されている場合、インストールが試行されたことを確認できます。
- 「ステータス」列の下にある、「警告付きでプロビジョニング済み」と表示されている警告を選択します。
- 問題に関する追加情報が表示されたブレードが開きます。
- ブレードの上部にある「Citrix エージェントのインストールを再試行」ボタンを選択して、VDA のインストールを再試行します。
- Citrix エンタイトルメントが割り当てられたときに Cloud PC に VDA がすでにインストールされている場合、または VDA がインストールされたカスタムイメージを使用して Cloud PC をプロビジョニングしている場合は、バージョン 2209 以降であることを確認してください。2203 LTSR バージョンを使用している場合は、2203 CU3 以降であることを確認してください。
- Cloud PC で PowerShell 実行ポリシーが正しく構成されていることを確認してください。詳細については、前提条件を参照してください。
- Cloud PC でソフトウェアのインストールを制限するセキュリティ構成がないことを確認してください。
- インストールまたは構成の問題が Intune のインストールプロセスに関連している場合、Cloud PC の以下のログに追加情報が含まれている可能性があります。
- C:\Packages\Plugins\Microsoft.Compute.CustomScriptExtension<version>\Status
- C:\WindowsAzure\Logs\Plugins\Microsoft.Compute.CustomScriptExtension<version>\CommandExecution.log
- C:\WindowsAzure\Logs\Plugins\Microsoft.Compute.CustomScriptExtension<version>\CustomScriptHandler.log
- インストールまたは構成の問題が VDA インストーラーまたは VDA 登録ツールに関連している場合、Cloud PC の以下のログに追加情報が含まれている可能性があります。
- VDA installation logs: %temp%\Citrix\XenDesktop Installer
- VDA Registration Tool: C:\CitrixRegistrationToolFolder\WebSocketVdaRegistrationTool
インストールが正常に完了してもVDAが登録されない
- HDX Rendezvous V2の要件と考慮事項を確認してください。
- Cloud PCのイベントビューアーでアプリケーションログを確認し、Citrix Desktop Serviceのエラーと警告を探してください。
Zscalerインターネットアクセス (ZIA) でHDXセッションが失敗する
Zscaler Internet AccessはデフォルトでTLSインスペクションを実行します。Citrix Rendezvous V2はパケット復号化またはTLSインスペクションをサポートしていません。CitrixエンドポイントでTLSインスペクションを有効にすると、HDXセッションが失敗します。
解決するには:
- ZIA管理コンソールで、ポリシー > SSLインスペクションに移動します。
- 次のドメインのバイパスルールを追加します。
-
*.nssvc.net(これは、Rendezvous V2接続にCitrix Gateway Serviceが使用するプライマリドメインです。さらに、すべてのCitrix Cloud必須エンドポイントをSSLインスペクションから除外します。完全なリストについては、接続要件を参照してください。)
- バイパスがTCP 443とUDP 443の両方のトラフィックに適用されることを確認してください。
- ポリシーを保存して適用します。
適用後、VDAがインストールされているCloud PCに接続し、コマンドプロンプトを開いてctxsession.exe -vを使用してテストします。出力はUDP -> DTLS -> CGP -> ICAまたはTCP -> SSL -> CGP -> ICAと表示されるはずです。
ゼットスケーラープライベートアクセス(ゼットピーエー)におけるエイチディーエックスのレイテンシー問題
Zscaler Private Accessは、Citrix Gateway Serviceに到達する前に、独自のインフラストラクチャを介してトラフィックをトンネルします。これにより、HDXセッションに遅延が追加され、断続的な接続障害が発生する可能性があります。
解決策:
- ZPA管理コンソールで、Citrix Gateway Serviceエンドポイント用に新しいアプリケーションセグメントを作成します。
- ドメイン:
*.nssvc.net,*.c.nssvc.net,*.g.nssvc.net - ポート: TCP 443 および UDP 443
- このセグメントのアクセスポリシーをZPAをバイパスに設定します (トンネルしない)。
- Windows 365 Cloud PCにアクセスするユーザーグループにポリシーを適用します。
注:
組織で二重ワイルドカードドメインパターン (
*.*.nssvc.net) を許可できない場合は、代わりに代替形式*.c.nssvc.netおよび*.g.nssvc.netを使用してください。