This content has been machine translated dynamically.
Dieser Inhalt ist eine maschinelle Übersetzung, die dynamisch erstellt wurde. (Haftungsausschluss)
Cet article a été traduit automatiquement de manière dynamique. (Clause de non responsabilité)
Este artículo lo ha traducido una máquina de forma dinámica. (Aviso legal)
此内容已经过机器动态翻译。 放弃
このコンテンツは動的に機械翻訳されています。免責事項
이 콘텐츠는 동적으로 기계 번역되었습니다. 책임 부인
Este texto foi traduzido automaticamente. (Aviso legal)
Questo contenuto è stato tradotto dinamicamente con traduzione automatica.(Esclusione di responsabilità))
This article has been machine translated.
Dieser Artikel wurde maschinell übersetzt. (Haftungsausschluss)
Ce article a été traduit automatiquement. (Clause de non responsabilité)
Este artículo ha sido traducido automáticamente. (Aviso legal)
この記事は機械翻訳されています.免責事項
이 기사는 기계 번역되었습니다.책임 부인
Este artigo foi traduzido automaticamente.(Aviso legal)
这篇文章已经过机器翻译.放弃
Questo articolo è stato tradotto automaticamente.(Esclusione di responsabilità))
Translation failed!
自动化配置故障排除以及其他相关信息
重要提示:
有关自动化配置的常见错误消息和相应的解决方案,请参阅知识中心文章 CTX277730 中的 故障排除常见问题解答。
自动化配置工具错误
自动化配置工具操作有时会产生错误。发生这种情况时,在处理诸如计算机目录、交付组或组策略等组件时可能会出现故障。使用 OnErrorAction 和延续参数,您可以在处理过程中捕获错误、解决错误并从中断处继续。
默认的 OnErrorAction 值为 StopCompEnd。发生错误时,工具会完成处理当前组件。不会处理其他组件,并且错误不会传递到下游的依赖组件。解决任何错误后,您可以重新运行应用了任何延续参数的 cmdlet。
错误时操作参数
您可以在迁移命令上定义 OnErrorAction 参数值,以控制工具如何响应在处理组件时发现的错误。
本表格列出了参数值及其对应的说明:
| 值 | 详细说明 |
|---|---|
Continue |
尽力处理所有组件中的尽可能多的部分。 |
Pause |
在处理结束时暂停并提示您继续或停止。 |
StopCompEnd |
尝试尽可能多地处理组件。在组件处理完成后停止。(默认) |
StopImmediately |
当发现错误时,处理停止。 |
迁移命令小程序
您可以将 OnErrorAction 参数应用于以下迁移命令:
Compare-CvadAcToSiteImport-CvadAcToSiteMerge-CvadAcToSiteNew-CvadAcToSiteRestore-CvadAcToSite
示例:Merge-CvadAcToSite -OnErrorAction StopImmediately
恢复操作参数
这些参数定义了当操作因错误而暂停或停止后,工具如何恢复。
您可以将恢复参数应用于包含以下 OnErrorAction 参数值之一的迁移 cmdlet:
PauseStopCompEndStopImmediately
此表展示了参数值及其对应的描述:
| 值 | 详细说明 |
|---|---|
-AllRemaining |
需要一个起始组件。处理将从起始组件开始,并处理所有剩余组件。将处理多个组件。 |
-Resume |
使用 CurrentComponent.txt 中的组件作为起点。所有剩余组件都设置为 true。将处理多个组件。 |
-Repeat |
使用 CurrentComponent.txt 中的组件作为起点。所有剩余组件都设置为 false。仅处理一个组件。 |
最后处理的组件存储在 AutoConfig 文件夹中的 CurrentComponent.txt 文件中。不建议编辑此文件。
如果您指定 -Resume 或 -Repeat,并且 CurrentComponent.txt 缺失或无效,则处理将停止,并提示您选择一个组件。
在 CustomerInfo.yml 文件中设置错误时操作
您还可以在 CustomerInfo.yml 文件中设置 OnErrorAction 值。使用以下 cmdlet 设置这些值:
- 对于新文件:
New-CvadAcCustomerInfoFile -OnErrorAction Continue | Pause | StopCompEnd | StopImmediately - 对于现有文件:
Set-CvadAcCustomerInfoFile -OnErrorAction Continue | Pause | StopCompEnd | StopImmediately
日志
运行任何 cmdlet 都会创建一个日志文件,并在主历史日志文件中生成一个条目。所有操作日志文件都放置在备份文件夹中。所有日志文件名都以 CitrixLog 开头,然后显示自动配置操作以及 cmdlet 执行的日期和时间戳。日志不会自动删除。
主历史日志位于 *%HOMEPATH%\Documents\Citrix\AutoConfig* 中,文件名为 History.Log。每次 cmdlet 执行都会生成一个主日志条目,其中包含执行的日期、操作、结果、备份和日志文件位置。
您还可以使用 New-CvadAcZipInfoForSupport cmdlet 收集日志,以便发送给 Citrix 以获得支持。此 cmdlet 会将所有日志和 .yml 文件压缩到一个单独的 zip 文件中。客户敏感信息(CustomerInfo.yml 和 CvadAcSecurity.yml)不包含在此 zip 文件中。Icon.yml 文件也因其大小而被排除。此 zip 文件将放置在 %HOMEPATH%\Documents\Citrix\AutoConfig 中,并根据日期和时间戳命名为 CvadAcSupport_yyyy_mm_dd_hh_mm_ss.zip。此 zip 文件还可以用作备份。
每个日志文件都包含以下内容:
- 操作的名称以及检查模式是否已启用
- 开始和结束日期和时间
- 每个组件的操作以及成功/失败通知的多个条目
- 所采取操作的摘要,包括创建对象的各种计数
- 在适用情况下的建议修复方案
- 适用的备份文件夹位置
- 主日志位置
- 持续时间
诊断文件
诊断文件可帮助您确定和解决问题。运行操作时会创建以下文件。它们位于 %HOMEPATH%\Documents\Citrix\AutoConfig 下特定于操作的子文件夹中。在提供问题解决支持信息时,请包含这些文件。
导出
PoshSdk_yyyy_mm_dd_hh_mm_ss.ps1
此文件统计为将站点配置导出到文件而进行的所有 Broker PowerShell SDK 调用。
导入、合并、还原、同步、备份、比较
Transaction_yyyy_mm_dd_hh_mm_ss.txt
此文件记录每个 Rest API 调用和相关信息。
RestApiContent_yyyy_mm_dd_hh_mm_ss.txt
此文件包含所有 Add、Update 和 Delete Rest API 内容。
由依赖项导致的问题
由于缺少依赖项,导入和合并可能会失败。一些常见问题包括:
- 组策略中缺少交付组筛选器。导致这种情况的常见原因是交付组尚未导入。
- 应用程序导入或合并失败。常见原因是缺少尚未导入的交付组或应用程序组。
- 应用程序组缺少 RestrictToTag。常见原因是尚未导入的标签。
- 主机连接失败。常见原因是 CvadAcSecurity.yml 文件中缺少安全信息。
- 计算机目录失败。常见原因是未导入主机连接。
- 计算机目录和交付组中缺少计算机。常见原因是未在 Active Directory 中找到计算机。
- 交付组中缺少用户。常见原因是未在 Active Directory 中找到用户。
建议事项
- 请勿同时运行多个自动化配置实例。运行多个并发实例会在云站点中产生不可预测的结果。如果发生这种情况,请重新运行一个自动化配置实例,以使站点达到预期状态。
- 运行自动化配置时,请勿在 Studio 中操作或更改数据。
- 始终在 Studio 中目视验证合并、导入或还原结果,以确保云站点符合预期。
文件夹
默认文件夹根位置
所有自动化配置工具操作都在根文件夹或其内部的子文件夹中进行。根文件夹位于 %HOMEPATH%\Documents\Citrix\AutoConfig。
导出
所有导出的文件都放置在两个文件夹位置,以方便使用并提供导出历史记录。导出始终放置在根文件夹中。副本放置在名为 Export 的子文件夹中,其中包含导出日期和时间。
根文件夹始终包含最新的导出的本地站点配置。每个 Export 子文件夹都包含在指定日期和时间完成的导出,这维护了导出历史记录。您可以使用任何 Export 子文件夹来配置云站点。自动化配置不会删除或修改现有的导出子文件夹。
导入/合并/同步/比较
Import、Merge 和 Compare 操作始终源自根文件夹中的文件。每个操作都会创建一个子文件夹,根文件夹中的文件将复制到该子文件夹中,从而提供云站点更改源文件的历史记录。
恢复
Restore 操作使用现有子文件夹配置云站点。源文件夹在必需的 -RestoreFolder 参数上指定。与其他命令不同,不会创建新的子文件夹,因为 Restore 操作使用现有子文件夹。恢复文件夹可以是根文件夹,但仍必须在 -RestoreFolder 参数上指定。
备份
自动配置会初始化、更新和备份云站点配置。随着时间的推移,云站点上可能会更改许多不同的配置。为了方便长期使用并保留历史更改,自动配置使用一种保留方案来保存此更改历史记录,并提供一种恢复早期状态的方法。
云站点配置备份始终会保存到名为 Backup 的子文件夹中,其中包含备份的日期和时间。自动配置不会删除或修改现有的导出子文件夹。
您可以使用备份来恢复特定组件或整个配置。要恢复整个交付组和计算机目录组件,请使用以下 cmdlet:
Restore-CvadAcToSite -RestoreFolder %HOMEPATH%\Documents\Citrix\AutoConfig/Backup_yyyy_mm_dd_hh_mm_ss -DeliveryGroups -MachineCatalogs
注意:
上述 cmdlet 中的备份文件信息基于您自己的备份。
要恢复整个云站点配置,请使用以下 cmdlet:
Restore-CvadAcToSite -RestoreFolder %HOMEPATH%\Documents\Citrix\AutoConfig/Backup_yyyy_mm_dd_hh_mm_ss
注意:
上述 cmdlet 中的备份文件信息基于您自己的备份。
更改默认根文件夹
Export、Import、Merge、Sync 和 Compare 操作可以通过使用 –AlternateFolder 参数更改默认根文件夹。每个操作子文件夹的创建和管理与之前描述的相同。
复制到子文件夹的文件
所有扩展名为“.yml”的文件都将复制到操作子文件夹,但以下文件除外:
- 客户信息.yml
- 区域映射.yml
- CvadAcSecurity.yml
自动故障安全云站点备份
在运行更改配置的操作之前,会创建当前云站点配置的备份。这包括 Import、Merge、Sync 和 Restore 参数。备份始终位于操作子文件夹下的子文件夹中。
在 Restore 的情况下,备份文件夹是 -RestoreFolder 参数中指定的文件夹的子文件夹。
自动化
通过抑制提示和在 cmdlet 完成时显示日志结果,可以在自动化脚本中运行自动化配置工具 cmdlet,而无需管理员干预。您还可以使用 CustomerInfo.yml 文件设置参数以实现相同目的。
将以下参数添加到云修改 cmdlet 以抑制提示的显示。
-Confirm $false
将以下参数添加到 cmdlet 以抑制在 cmdlet 完成时显示日志。
-DisplayLog $false
将以下参数添加到 cmdlet 以禁止向 PowerShell 命令窗口记录日志。
-Quiet
作为另一种方法,可以将以下参数放置在 CustomerInfo.yml 文件中。
Confirm: False
DisplayLog: False
Exporting from PCs other than the Delivery Controller™
自动化配置工具使用多个 Citrix PowerShell 开发工具包 将本地站点配置导出到文件。这些 开发工具包 会自动安装在 交付控制器 上,使工具无需额外操作即可在 交付控制器 上运行。在非 交付控制器 计算机上运行时,需要安装工具所需的 Citrix PowerShell 开发工具包 集。此 开发工具包 集是 Citrix Studio 的一部分,可以从 Citrix Virtual Apps and Desktops™ 安装介质安装。
注意:
自动化配置无法在 Cloud Connector 上运行。
迁移到 Citrix Cloud™ 政府版 和日本控制平面
Citrix Cloud Government 和日本控制平面环境使用不同的访问点进行身份验证和分配访问令牌。此独特要求适用于任何访问云的自动化配置工具。请执行以下步骤以在这些环境中使用自动化配置。
- In the %HOMEPATH%\Documents\Citrix\AutoConfig folder, edit CustomerInfo.yml.
-
根据您要连接到的环境,将以下行之一添加到 CustomerInfo.yml(如果已存在,则进行更改)。
Environment: 'ProductionGov'或
Environment: 'ProductionJP'
自动化配置现在可以在这些环境中使用了。
Citrix 云数据收集
有关 Citrix Cloud 收集的信息,请参阅 Citrix Cloud 服务客户内容和日志处理。
附加的资源
讨论论坛
访问 Citrix 自动化配置讨论论坛。
视频
在 YouTube 上观看 Citrix 虚拟应用和桌面自动化配置工具揭秘。
培训
云学习中心包含构建服务部署的分步视频指南,包括本文中描述的任务。请参阅 将 Citrix Virtual Apps and Desktops 迁移到 Citrix Cloud 学习路径。
共享
共享
This Preview product documentation is Citrix Confidential.
You agree to hold this documentation confidential pursuant to the terms of your Citrix Beta/Tech Preview Agreement.
The development, release and timing of any features or functionality described in the Preview documentation remains at our sole discretion and are subject to change without notice or consultation.
The documentation is for informational purposes only and is not a commitment, promise or legal obligation to deliver any material, code or functionality and should not be relied upon in making Citrix product purchase decisions.
If you do not agree, select I DO NOT AGREE to exit.