This content has been machine translated dynamically.
Dieser Inhalt ist eine maschinelle Übersetzung, die dynamisch erstellt wurde. (Haftungsausschluss)
Cet article a été traduit automatiquement de manière dynamique. (Clause de non responsabilité)
Este artículo lo ha traducido una máquina de forma dinámica. (Aviso legal)
此内容已经过机器动态翻译。 放弃
このコンテンツは動的に機械翻訳されています。免責事項
이 콘텐츠는 동적으로 기계 번역되었습니다. 책임 부인
Este texto foi traduzido automaticamente. (Aviso legal)
Questo contenuto è stato tradotto dinamicamente con traduzione automatica.(Esclusione di responsabilità))
This article has been machine translated.
Dieser Artikel wurde maschinell übersetzt. (Haftungsausschluss)
Ce article a été traduit automatiquement. (Clause de non responsabilité)
Este artículo ha sido traducido automáticamente. (Aviso legal)
この記事は機械翻訳されています.免責事項
이 기사는 기계 번역되었습니다.책임 부인
Este artigo foi traduzido automaticamente.(Aviso legal)
这篇文章已经过机器翻译.放弃
Questo articolo è stato tradotto automaticamente.(Esclusione di responsabilità))
Translation failed!
AWS VMの電源管理
必要な権限については、「Required AWS permissions」を参照してください。
インスタンスの休止
休止プロセスでは、インスタンスのインメモリ状態と、そのプライベートIPアドレスおよびElastic IPアドレスが保存され、中断したところから正確に再開できます。
インスタンスに休止が指示されると、インメモリ状態がルートEBSボリュームのファイルに書き込まれ、その後シャットダウンされます。Amazon EBSボリュームは、インスタンスにアタッチできる耐久性のあるブロックレベルのストレージデバイスです。ボリュームをインスタンスにアタッチすると、物理ハードドライブと同じように使用できます。インスタンスのルートEBSボリュームを暗号化します。暗号化により、メモリからEBSボリュームにコピーされる機密データが適切に保護されます。EBS暗号化の詳細については、「Amazon EBS encryption」を参照してください。
サポートされているインスタンスの休止には、以下の制限があります。
- インスタンスメモリ(RAM)は最大150 GBまでのみサポートされます
- UEFIブートモードはサポートされていません
- EBSボリュームタイプとしてサポートされているのは、汎用SSDとプロビジョンドIOPS SSDのみです。
休止をサポートするVMの作成
休止をサポートするVMを作成するには:
- ホスト接続を作成します。「Connection to AWS」を参照してください。
- EBSルートが暗号化され、Stop-Hibernateプロパティが有効になっているインスタンスを起動します。インスタンスの起動方法、ルートEBSボリュームの暗号化、および休止の有効化の詳細については、https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/launching-instance.html/を参照してください。このインスタンスをマスターイメージとして使用してAMIを作成します。
-
マスターイメージを準備します。
- マスターイメージにVDAをインストールします。Citrixでは、最新の機能にアクセスできるように、最新バージョンをインストールすることをお勧めします。マスターイメージにVDAをインストールしないと、カタログの作成が失敗します。VDAのインストール方法の詳細については、「Install VDAs」を参照してください。
- アプリケーションとデスクトップがメンバーであるドメインにマスターイメージを参加させます。マシンが作成されるホストでマスターイメージが利用可能であることを確認します。
- そのインスタンスからAMIを作成します。インスタンスからAMIを作成する方法については、「Amazon EC2インスタンスからAMIを作成する」を参照してください。
-
New-ProvSchemeコマンドを使用してマシンカタログを作成します。AwsCaptureInstancePropertiesカスタムプロパティをTrueに設定します。Web StudioでAWSインスタンスプロパティを有効にする方法については、「Web StudioでのAWSインスタンスプロパティの適用と運用リソースのタグ付け」を参照してください。New-ProvScheme -AdminAddress "xxx" -CleanOnBoot -CustomProperties "AwsCaptureInstanceProperties,true;" -HostingUnitName "xxx" -IdentityPoolName $catalog_name -InitialBatchSizeHint 1 -MasterImageVM "xyz.template" -NetworkMapping @{"0"="XDHyp:\HostingUnits\MyConn\\us-east-2a.availabilityzone\10.0.0.0``/24 (vpc-0f1771e45671aedcd).network"} -ProvisioningSchemeName $catalog_name -RunAsynchronously -Scope @() -SecurityGroup @("xxx") -ServiceOffering "xxx" <!--NeedCopy-->PowerShellコマンドを使用してマシンカタログを作成する方法については、https://developer-docs.citrix.com/projects/citrix-daas-sdk/en/latest/を参照してください。
次の場合に、休止状態にできるVMが作成されます。
- Stop-Hibernateプロパティが有効になっているマスターイメージから作成されたAMIを選択した場合。
- マスターVMがドメインに参加しており、VDAがインストールされている場合。
- 休止状態を処理できる正しいVMサイズ(サービスオファリング)を選択した場合。
次の場合に、New-ProvSchemeコマンドは適切なエラーメッセージとともに失敗します。
- マスターVMは休止状態が有効になっているが、サービスオファリングが休止状態を処理できない場合。
- マスターVMがドメインに参加しておらず、VDAがインストールされていない場合。
サービスオファリングとAMIの休止状態
サービスオファリングとAMI(テンプレート)の休止状態を取得するには、次のコマンドを実行します。
Get-HypConfigurationObjectForItem 'XDHyp:\HostingUnits\MyConn\WIN2016-ADDC-2021.09.10.145334-a1968709-10c4-47d5-9642-21e743159a7b (ami-0e6c5b33a52d2a6b6).template'Get-HypConfigurationObjectForItem 'XDHyp:\HostingUnits\MyConn\R6i Sixteen Extra Large Instance.serviceoffering'
既存の休止状態をサポートするプロビジョニングスキームのサービスオファリングを更新する
-
Set-ProvSchemeコマンドを実行します。例:Set-ProvScheme -ProvisioningSchemeName <String> -ServiceOffering <String> <!--NeedCopy-->
サービスオファリングに互換性がない場合、システムは例外メッセージを表示します。
休止状態をサポートするマシンカタログを作成する
マシンカタログを作成する際、休止状態をサポートするマシンプロファイルを使用できます。
- カタログ作成ウィザードで、マシンプロファイルの選択まで指示に従います。
- マシンテンプレートページで、マシンプロファイルの選択をクリックし、マシンプロファイルを選択します。
-
仮想マシンページで、編集アイコンをクリックし、VMを選択します。
注:
マシンプロファイルが休止状態を有効にしている場合、システムは休止状態にできるVMのみを表示します。
-
画面の指示に従ってすべての設定を完了します。概要ページには、カタログの休止状態が表示されます。
注:
マシンカタログの編集で、マシンプロファイルを休止状態が有効なものに変更すると、それに応じてVMを再構成するよう求められます。
休止状態をサポートするマシンカタログを更新する
既存のマシンカタログを休止状態をサポートしないマシンカタログで更新しようとすると、適切なエラーメッセージが表示されて更新が失敗します。
休止状態のVMの電源管理
休止状態のVMに対して、次の電源管理操作を実行できます。
- 実行状態からVMを一時停止する。
- 一時停止状態からVMを再開する。
- 一時停止状態からVMを再起動する。
共有
共有
この記事の概要
This Preview product documentation is Citrix Confidential.
You agree to hold this documentation confidential pursuant to the terms of your Citrix Beta/Tech Preview Agreement.
The development, release and timing of any features or functionality described in the Preview documentation remains at our sole discretion and are subject to change without notice or consultation.
The documentation is for informational purposes only and is not a commitment, promise or legal obligation to deliver any material, code or functionality and should not be relied upon in making Citrix product purchase decisions.
If you do not agree, select I DO NOT AGREE to exit.