StoreFront

累积更新 7 (CU7)

发布日期:2025 年 8 月 28 日

系统必备条件

StoreFront™ 2203 LTSR CU7 需要 .NET 8。如果尚未安装,安装程序将自动安装 .NET 8。

有关详细信息,请参阅系统要求

适用于 HTML5 的 思杰工作区应用程序

此版本包括适用于 HTML5 的 思杰工作区应用程序 25.5.0.19

2203 LTSR CU7 中的新增功能

Citrix 许可遥测

StoreFront 会收集用户登录和您的配置的遥测数据。有关详细信息,请参阅遥测

2203 LTSR 累积更新 7 (CU7) 中已修复的问题

StoreFront 2203 LTSR CU7 包含 CU6 中包含的所有修复,以下是新的修复:

  • 使用 PowerShell 命令 Set-STFStoreService $storeService -IcaFileSigning $true 启用 ICA® 签名时,该命令未在证书上设置必要的权限,导致 ICA 签名失败。[CVADHELP-26649]

  • 在 StoreFront 自定义 API 中,用户可以通过将内容插入 ID 为 customBottom 的元素来包含自定义页脚。但是,有两个部分包含 ID 相同的元素 customBottom,这可能会导致自定义出现意外行为。[CVADHELP-26564]

  • 用户首次访问网站一年后,自动启动桌面功能将无法正常工作。[CVADHELP-26817]

  • 格式错误的 URL 可能会导致内部服务器错误,并带有二进制响应正文。[CVADHELP-26916]

  • 启用套接字池时,Citrix 订阅同步服务可能会在 StoreFront 服务器上显示高内存使用率,或导致端口耗尽,从而导致服务不可用。[CVADHELP-26838]

  • 启用 HDX™ Direct 时,当客户端通过网关发起 HDX 连接时,StoreFront 会在 ICA 文件中包含不必要的 VDA 主机详细信息。[CVADHELP-27112]

  • HTML 文件 http-equiv 标签中定义的内容安全策略已更新,以阻止内联脚本。[CVADHELP-27487]

    注意:

    由于此更新,使用 eval 或将内联脚本插入 DOM 的 StoreFront 自定义将不再起作用。

  • 当 Cloud Connector 在 LHC 模式下运行,并且用户尝试启动可从多个位置访问的资源时,如果资源未立即可用,会话可能无法启动。

    出现此问题的原因是,在检查资源就绪状态后,StoreFront 可能会将请求发送到与最初用于启动资源的连接器不同的连接器。[CTXENG-64445] [CVADHELP-28639]

  • 当 NTLM 身份验证被禁用时,StoreFront 收藏夹不会在 StoreFront 服务器之间同步。[CVADHELP-27550]

累积更新 7 (CU7)