Citrix Virtual Apps and Desktops

解决 Always On Tracing 的常见问题

适用于: Citrix Virtual Apps and Desktops 2402 CU4、2507 CU1、2511、2603 及更高版本,DaaS

要求: AOT 日志服务器已部署;AuthKey 在 Director 或 Monitor 设置中配置

Always On Tracing (AOT) 持续捕获所有 Citrix 组件(VDA、Delivery Controller、StoreFront、License Server 和 Citrix Workspace App)的日志。当报告问题时,数据已存在。本文介绍如何使用 Citrix Director 或 Monitor 中的“日志”节点来识别问题原因,以及如何从 Director 或 Monitor 导出日志以提交给 Citrix 技术支持。

开始之前 — 为每个场景收集以下信息

  • 受影响的用户或计算机 — 特定用户名、VDA 主机名或交付组名称
  • 故障时间 — 即使是近似的时间范围也有助于缩小默认时间筛选器。调整时间范围以涵盖报告故障之前的时间段。
  • 范围 — 一个用户、一台计算机还是整个环境?仅凭范围通常就能在打开日志之前指出正确的故障模式
  • 最近的更改 — 相关时间段内的任何 CVAD 更新、组策略更改、电源管理更改或网络更改

Director 和 Monitor 中的日志节点

“日志”节点在 Citrix Director(本地 CVAD)和 Citrix Monitor (DaaS) 中均可用。要访问它,请从左侧导航面板中选择“日志”。这两种环境中的界面相同。

AOT Monitor 日志(带注释)

  1. 搜索栏 — 关键字、事务 ID、类别或主机名
  2. 时间筛选器 — 选择涵盖故障的时间范围
  3. 类别筛选器 — 按事件类型筛选
  4. 日志级别筛选器 — 按严重性筛选
  5. 主机名筛选器 — 选择一台或多台计算机
  6. 应用按钮 — 应用所有活动的筛选器选择
  7. 导出图标 — 下载日志以提交给 Citrix 技术支持

筛选器栏

筛选器栏有四个筛选器和一个单独的应用按钮。首先设置筛选器,然后单击应用以刷新日志视图。当前日志计数显示在筛选器栏下方 — 例如,批次 1 中有 850 条日志。使用批次导航箭头翻阅大型结果集。

筛选器 功能 选项
时间 设置日志检索的时间窗口。将其设置为在报告的故障发生之前开始的时间窗口,以捕获导致故障的事件。 最近 5 分钟 · 最近 1 小时 · 最近 24 小时 · 最近 48 小时 · 最近 7 天 · 自定义 (UTC) (仅限 CVAD 2603 及更高版本的云版本)
类别 按事件类型筛选。每个类别对应于 Citrix 组件生命周期的特定部分。包括一个“搜索类别”字段,可按名称快速查找类别。 应用程序启动 · 剪贴板 · CWA-启动后 · CWA-启动前 · 数据库 · 设备 · 等
日志级别 按严重性筛选。选择一个或多个。选中后,按钮标签会显示选定的数量(例如,已选择 1 个日志级别)。 信息 · 警告 · 错误 · 严重
主机名 筛选到一个或多个特定计算机。包括一个“搜索主机”字段和当前向日志服务器发送日志的所有计算机的复选框列表。激活时,显示 已选择 N 个主机名 所有已向日志服务器注册的计算机
日志级别 何时使用
信息 标准组件事件 — 会话已启动、VDA 已注册、许可证已签出。用于查看完整的生命周期序列。
警告 可能表明存在问题的非关键问题 — 会话断开连接、空闲超时、心跳警告。从此处开始处理断开连接场景。
错误 需要调查的故障 — 启动错误、注册失败、许可证耗尽。从此处开始处理大多数场景。
严重 严重影响服务的故障 — 通常是组件崩溃或不可恢复的状态

日志表 — 列

日志表默认显示每个条目的五列。可以通过单击“列”按钮添加新列。单击任意行上的 > 展开箭头可查看完整的日志消息和附加字段。

AOT 监控日志主界面

“日志”表,其中“应用程序启动”类别处于活动状态。日志计数和批处理导航显示在表上方。使用 > 箭头展开任意行以阅读完整消息。

显示内容
时间 (UTC) 事件的 UTC 时间戳,精确到毫秒。按升序排序可按事件发生的顺序读取事件序列。
日志级别 严重性标记:信息、警告、错误或严重
消息 来自组件的日志消息。在表中已截断 — 单击行上的 > 展开箭头可阅读完整消息。完整消息是主要的诊断文本。
主机名 生成日志条目的计算机
主机类型 组件类型:DDC、StoreFront、WVDA (Windows VDA)、CWAWindows 以及其他根据向日志服务器注册的内容而定的类型

为 Citrix 技术支持导出日志

导出图标(上述带注释屏幕截图中的 7)显示在“日志”部分的右上角。使用它将当前筛选的日志视图下载为文件。导出前:

版本可用性:

导出图标在 DaaS 的 Cloud 129(2026 年 4 月至 5 月)及更高版本中可用,在 Citrix Virtual Apps and Desktops 的 CVAD 2603 及更高版本中可用。此选项在早期版本中不可用。

需要 AuthKey:

仅当在 Director 或 Monitor 设置中配置了 AuthKey 时,“日志”节点才会显示数据。AuthKey 在日志服务器设置期间生成。如果没有它,“日志”节点将不显示任何条目。

场景 1:会话启动失败

用户单击已发布的桌面或应用程序并收到启动错误。会话从未打开。错误可能显示在 Citrix Workspace App 屏幕上,或者进度条停滞并超时,没有会话连接。

在“日志”节点中,将 Category 设置为 Application Launch,将 Log Level 设置为 Error,并调整 Time 以涵盖故障时间窗口。单击 Apply。按 Time (UTC) 升序排序,并同时读取 MessageHost Type 列 — 它们显示启动路径中哪个组件失败以及它报告了什么。

仅供参考:

以下日志消息是说明性示例。您环境中的实际消息遵循相同的格式和列结构,但措辞可能有所不同。

示例:交付组中没有可用的 VDA

DDC 收到启动请求,但无法分配桌面。交付组中的所有 VDA 均未注册或已达到会话容量。

时间 (UTC) 日志级别 消息 主机名 主机类型
2026-07-20T09:14:22.1034Z 信息 应用程序启动:用户 DOMAIN\jsmith 从交付组“Windows 11 VDAs”请求桌面 DDC-01 DDC
2026-07-20T09:14:22.3841Z 错误 应用程序启动:未找到合适的桌面 — 交付组“Windows 11 VDAs”中的所有 VDA 均未注册或已达到会话容量 DDC-01 DDC
2026-07-20T09:14:22.4102Z 错误 应用程序启动:用户 DOMAIN\jsmith 启动失败 — 无可用资源 STF-01 StoreFront

DDC 的错误信息表明代理无法找到可用的 VDA。在 Web Studio → 搜索计算机中检查 VDA 注册。有关 VDA 注册故障排除,请参阅 场景 2:VDA 注册失败

示例:VDA 已分配但会话初始化失败

DDC 分配了一个 VDA,但 VDA 无法启动会话。常见原因:FSLogix 或漫游配置文件容器故障、组策略处理错误或 VDA 资源耗尽。

时间 (UTC) 日志级别 消息 主机名 主机类型
2026-07-20T09:22:11.0234Z 信息 应用程序启动:为用户 DOMAIN\jsmith 选择了 VDA WIN11MS-CC-VDA4 DDC-01 DDC
2026-07-20T09:22:11.8820Z 错误 应用程序启动:用户 DOMAIN\jsmith 的会话初始化失败 — FSLogix 配置文件容器无法挂载到 \fileserver\profiles\jsmith.vhdx WIN11MS-CC-VDA4 WVDA
2026-07-20T09:22:12.0011Z 错误 应用程序启动:启动请求失败 — VDA WIN11MS-CC-VDA4 报告用户 DOMAIN\jsmith 的会话准备错误 DDC-01 DDC

来自主机类型 WVDA 的错误将 VDA 识别为故障点,并且消息显示了确切原因。单击该行上的 > 展开箭头以阅读完整消息,其中包含完整的配置文件容器路径和错误代码。

示例:CWA 启动后虚拟通道错误

会话在 VDA 端创建,但 CWA 客户端无法建立 ICA® 虚拟通道连接。将主机名筛选到 CWA 计算机以查看客户端错误。

时间 (UTC) 日志级别 消息 主机名 主机类型
2026-07-20T09:31:04.5521Z 信息 应用程序启动:无缝主机虚拟驱动程序已成功初始化 WIN11MS-CC-VDA4 WVDA
2026-07-20T09:31:05.1204Z 错误 CWA-POSTLAUNCH::虚拟通道:加载虚拟驱动程序失败 — 通道协商超时。检查端口 1494 和 2598 的防火墙规则。 Win22-CC-01 CWA Windows 平台

主机类型 CWAWindows 出现 CWA-POSTLAUNCH 错误意味着 VDA 已就绪,但客户端与 VDA 之间的 ICA 数据路径被阻止。验证从客户端计算机到 VDA 的端口 1494 和 2598 是否已打开。

场景 2:VDA 注册失败

VDA 在 Director 或 Web Studio → 搜索计算机中显示为 未注册。用户看到“目前没有可用的桌面。”已发布的桌面在 StoreFront™ 或 Citrix Workspace™ 中显示为灰色。

在“日志”节点中,将“类别”设置为“VDA 注册”,将“日志级别”设置为“错误”,并将“主机名”设置为受影响的 VDA 和 DDC。单击“应用”。同时读取注册握手的两端(即 VDA 行和 DDC 行在同一时间戳),可以准确显示故障发生的位置。

仅供参考:

以下日志消息是说明性示例。您环境中的实际消息遵循相同的格式和列结构,但措辞可能有所不同。

示例:VDA 无法访问 Delivery Controller

VDA 正在尝试注册,但 DDC 从未收到请求。仅显示 VDA 端的错误 — 在相同时间戳没有匹配的 DDC 行。

时间 (UTC) 日志级别 消息 主机名 主机类型
2026-07-20T08:30:11.2341Z 错误 注册:无法通过端口 443 联系 Delivery Controller DDC-01.domain.com — 连接超时 WIN11MS-CC-VDA4 WVDA
2026-07-20T08:30:41.2341Z 错误 注册:无法通过端口 443 联系 Delivery Controller DDC-01.domain.com — 连接超时 WIN11MS-CC-VDA4 WVDA
2026-07-20T08:31:11.2341Z 错误 注册:无法通过端口 443 联系 Delivery Controller DDC-01.domain.com — 连接超时 WIN11MS-CC-VDA4 WVDA

相同的错误以固定间隔重复出现,这是一个重试循环 — VDA 处于活动状态但被阻止。验证 VDA 到 DDC 的端口 80 和 443 是否已打开,并检查 VDA 上的 ListOfDDCs 注册表项是否存在陈旧或不正确的 DDC 地址。

示例:DDC 拒绝注册请求

VDA 已到达 DDC,但 DDC 拒绝注册它。VDA 和 DDC 行均显示 — 阅读 DDC 消息以了解拒绝原因。

时间 (UTC) 日志级别 消息 主机名 主机类型
2026-07-20T08:30:11.2341Z 信息 注册:VDA WIN11MS-CC-VDA4 尝试向 DDC-01.domain.com 注册 WIN11MS-CC-VDA4 WVDA
2026-07-20T08:30:11.8820Z 错误 注册:注册被拒绝 — 计算机帐户 WIN11MS-CC-VDA4$ 已禁用或在 Active Directory 中找不到 DDC-01 DDC

错误行来自主机类型 DDC — DDC 是故障点,而不是 VDA。单击 DDC 行上的 > 展开箭头以阅读完整的拒绝原因。常见原因:Active Directory 中禁用的计算机帐户、VDA/DDC 版本不匹配或许可证池耗尽。

示例:VDA 注册后立即注销

注册成功,但 DDC 在几秒钟内启动注销。这会循环重复。电源管理耗尽策略在 VDA 接受会话之前将其关闭。

时间 (UTC) 日志级别 消息 主机名 主机类型
2026-07-20T09:01:33.1240Z 信息 注册:VDA WIN11MS-CC-VDA4 已成功向 DDC-01.domain.com 注册 WIN11MS-CC-VDA4 WVDA
2026-07-20T09:01:47.4421Z 错误 电源管理: 电源管理耗尽已启动 — 计算机已根据交付组电源策略计划关机 WIN11MS-CC-VDA4 WVDA
2026-07-20T09:01:47.6830Z 错误 注册: VDA WIN11MS-CC-VDA4 已注销 — 原因: 电源管理耗尽 DDC-01 DDC

注册和注销之间 14 秒的间隔是关键线索。请检查 Web Studio → 交付组 → 电源管理,查看在工作时间生效的耗尽或关机计划。


注意:

本文中的场景是关于如何在 Citrix Director 或 Monitor 中搜索和调查日志的示例。同样的方法适用于您遇到的任何 Citrix 相关问题 — 会话故障、身份验证错误、连接问题、VDA 不稳定或任何其他组件级别的问题。设置正确的类别日志级别主机名筛选器,按时间 (UTC) 顺序读取日志序列,并展开单个行以读取完整的消息。记录第一个错误的组件以及消息内容将指出根本原因 — 无论场景如何。

提示 — 拥有 Citrix Aidrien 访问权限的 DaaS 客户: 从 AOT 日志中复制错误消息并直接粘贴到 Citrix Aidrien 中。Aidrien 将解释错误并提供建议的故障排除步骤。这可能无法自行解决所有问题,但它将缩小根本原因范围,并且在许多情况下会指导您找到解决方案 — 在您需要联系 Citrix 技术支持之前。

上报给 Citrix 技术支持

如果自助调查无法解决问题,请在提交支持工单时包含以下信息:

  • 涵盖故障时间段的导出日志文件 — 使用上面选项 7 中描述的导出图标。您可以根据情况通过两种方式导出:

    • 定向导出 — 应用时间、类别和主机名筛选器,然后导出。这为支持团队提供了一组针对该故障的重点日志。
    • 广泛导出 — 仅应用时间筛选器并导出,不使用任何其他筛选器。这为支持团队提供了故障时间段的完整日志视图,在范围不明确时非常有用。

    文件下载时,文件名将以 AOT 为前缀。请勿删除或重命名此前缀。您可以编辑文件名中后续的部分 — 但始终保留开头的 AOT

  • 从上述部分识别出的故障模式
  • CVAD 版本、组件版本(VDA、DDC、StoreFront)和日志服务器版本
  • 失败事件的事务 ID 或会话 ID — 可在“日志”节点搜索栏中使用占位符进行搜索:“按事务 ID、关键字、类别、主机名搜索日志”

由于 AOT 持续捕获日志,并且每个条目都包含主机名、主机类型和时间戳,Citrix 技术支持可以立即开始分析,而无需您重现问题或收集新的跟踪。

解决 Always On Tracing 的常见问题