This content has been machine translated dynamically.
Dieser Inhalt ist eine maschinelle Übersetzung, die dynamisch erstellt wurde. (Haftungsausschluss)
Cet article a été traduit automatiquement de manière dynamique. (Clause de non responsabilité)
Este artículo lo ha traducido una máquina de forma dinámica. (Aviso legal)
此内容已经过机器动态翻译。 放弃
このコンテンツは動的に機械翻訳されています。免責事項
이 콘텐츠는 동적으로 기계 번역되었습니다. 책임 부인
Este texto foi traduzido automaticamente. (Aviso legal)
Questo contenuto è stato tradotto dinamicamente con traduzione automatica.(Esclusione di responsabilità))
This article has been machine translated.
Dieser Artikel wurde maschinell übersetzt. (Haftungsausschluss)
Ce article a été traduit automatiquement. (Clause de non responsabilité)
Este artículo ha sido traducido automáticamente. (Aviso legal)
この記事は機械翻訳されています.免責事項
이 기사는 기계 번역되었습니다.책임 부인
Este artigo foi traduzido automaticamente.(Aviso legal)
这篇文章已经过机器翻译.放弃
Questo articolo è stato tradotto automaticamente.(Esclusione di responsabilità))
Translation failed!
已知问题和限制
-
每个环境仅支持一个日志服务器
当前架构每个环境仅支持一个 AOT 日志服务器,并且 Web Studio 和 Director/Monitor 都设计为仅使用一个日志服务器配置。所有组件都必须指向同一个日志服务器;目前不支持跨多个日志服务器配置或分发工作负载。此单个日志服务器最多可处理 128,000 个活动组件连接,每秒处理多达 10,000 个日志事件,这对于大多数部署来说已足够。由于这些限制基于连接容量和日志吞吐量,而不是组件数量,因此即使是非常大的环境也可以使用一个日志服务器运行,只要它们保持在吞吐量阈值内。
但是,在高峰活动期间日志量极高的客户可能会由于缺乏横向扩展而达到摄取或索引限制。未来版本将作为不断发展的架构的一部分,引入对多个日志服务器和更广泛扩展选项的支持。 -
在 XenServer 上托管的 Windows VM 上运行 AOT 日志服务器不受支持。 XenServer 不支持嵌套虚拟化,这会阻止 Docker 在客户机虚拟机内运行。因此,在此配置中无法部署日志服务器容器。
-
Windows 上的 Docker Desktop 需要活动用户会话才能运行 AOT 日志服务器
当 AOT 日志服务器使用 Docker Desktop 部署在 Windows VM 上时,容器在启动 Docker Desktop 的用户会话上下文中运行。Docker Desktop 被设计为基于用户会话的应用程序,并且不会作为系统级服务在 Windows 上运行。因此,如果用户注销,Docker Desktop 将停止,这会导致 AOT 日志服务器容器停止。由于此行为:当用户注销时,AOT 日志服务器会停止,因为部署依赖于特定的用户会话。其他管理员无法访问或管理正在运行的容器。
解决方法:保持用户会话处于活动状态或断开连接状态(不要注销),以确保 Docker Desktop 和 AOT 日志服务器容器继续运行。
建议 对于生产部署,请使用以下选项之一:
-
使用 Docker Engine 在 Linux VM 上部署 AOT 日志服务器
-
在支持的情况下使用基于 Citrix Connector Appliance (CCA) 的部署
这些选项允许日志服务器独立于用户会话运行,并提供更可靠的始终在线部署模型。
-
注意:
此方法在具有会话超时或严格安全策略的环境中可能不可靠。
此行为是 Windows 上 Docker Desktop 的已知限制,并非 AOT 日志服务器特有。
-
许可证服务器日志在 Director/Monitor 中显示不正确的 Host Type
在 Director 中查看来自许可证服务器的 AOT 日志时,主机类型列可能会错误地显示为 DDC 而不是 许可证服务器,即使主机名正确。
此问题仅限于主机类型在 Director 中的显示方式,不影响日志收集或功能。此问题已在最新的许可证服务器版本中解决,并从 许可证服务器版本:55000 或更高版本 开始修复。
-
在 Monitor 中查看 AOT 日志需要 Citrix Cloud Connector
使用 Citrix Monitor 查看 AOT 日志的客户必须在其环境中至少部署一个 Citrix Cloud Connector。此要求适用于 AOT 日志服务器的托管位置,包括 Linux VM、Windows VM 或 Citrix Connector Appliance。
Citrix Monitor 依靠在 Cloud Connector 上运行的 Monitor 服务从配置的日志服务器检索日志并在 UI 中显示。
如果没有 Windows Cloud Connector,则无法在 Monitor 中获取或显示 AOT 日志。
-
ADC Gateway 日志在 Citrix Director 中显示不正确
症状:在 Citrix Director 中查看 Citrix ADC Gateway 的 Always On Tracing (AOT) 日志时,您可能会观察到:
- 日志级别显示为 Error 而不是 Debug 或 Info。
- 消息列显示整个原始日志条目。
- 显示的时间戳与原始事件时间戳不同。
- 只有格式错误的 JSON 日志记录受到影响。有效的日志记录显示正确。
受影响的版本: Citrix ADC 早于 14.1-73.x 和 Citrix ADC 早于 15.1-8.x。
原因: Citrix ADC Gateway 上传了格式错误的 JSON 日志记录,AOT 日志服务器无法解析这些记录。因此,日志服务器存储原始日志条目并将其归类为错误。
解决方案: 将 Citrix ADC 升级到以下版本之一或更高版本:
- 14.1-73.x
- 15.1-8.x
已修复于: Citrix ADC 14.1-73.x 和 Citrix ADC 15.1-8.x。
-
AOT 日志服务器目前不支持符合 FIPS 要求的部署。有强制性 FIPS 要求的客户应推迟生产部署,直到 FIPS 支持可用。
不需要 FIPS 合规性的客户可以继续在受支持的环境中部署和评估 AOT 日志服务器。
共享
共享
在本文中
This Preview product documentation is Citrix Confidential.
You agree to hold this documentation confidential pursuant to the terms of your Citrix Beta/Tech Preview Agreement.
The development, release and timing of any features or functionality described in the Preview documentation remains at our sole discretion and are subject to change without notice or consultation.
The documentation is for informational purposes only and is not a commitment, promise or legal obligation to deliver any material, code or functionality and should not be relied upon in making Citrix product purchase decisions.
If you do not agree, select I DO NOT AGREE to exit.